Entering foreign tax on dividends - bug or feature?

I really like the way that Sharesight calculates the dividend I’ll have received on my stock and enters it in the net and gross dividend fields (assuming 0% tax). No more needs to be done for my domestic stocks, besides checking. It’s lovely.

However for foreign investments the next step behaviour is odd. You enter the foreign tax withheld into the field provided. But then, Sharesight keeps the NET dividend amount as it is, and updates the GROSS dividend by adding the tax amount to the net. I can’t imagine any situation in which this makes sense. The gross dividend is simply the number of shares I own times the dividend per share announced by the company. This cannot change. Once tax has been withheld, it’s the net dividend that decreases by the tax amount.

Of course I could manually update the net dividend field but I’d have to calculate it myself, because my trading platform reports the gross dividend and the tax deducted, not the net (surely this will be the case for all platforms?). I’d have to manually deduct the tax, so that sharesight can add it back again to get back to the gross dividend number it started with.

Doing this one by one for all dividends wouldn’t be practical. You can’t import the dividend numbers from a spreadsheet. So I can’t help thinking this is a bug. Any thoughts?

Hi @Ipseity welcome to the community! :wave:

So each dividend is made up of a net, taxable and gross figure. The gross figure is what is paid overall, a sum of the net & taxable figure. So when you are paid out a figure per share, that total amount is the gross amount.

If a stock pays 10c per share & you have 1000 shares, your gross amount is $100. If you’re taxed 15% of this amount then your net amount will be $85 and your taxable component is $15.

It sounds like you’re adding in the taxable amount once the dividend is added into Sharesight. If you pay the same % to tax for each payment, you can set this to apply automatically to each dividend. To do so, on the individual holding page click the ‘Holding Settings’ menu, then add in your tax % into the text box.

Without doing this, the entire gross amount will show as the net amount, and when you add tax you’ll get a greater gross amount.

Hi Jack, thanks for telling me about the % feature in the holding settings. I can see how using that would have avoided the problem. However, your reply suggests that manually entered tax is added to the net rather than deducted from the gross, which still doesn’t make sense to me and is the opposite treatment from the automated case. A bug, perhaps? Anyway, my portfolio is now in a knot, so I have written back to your direct email (thanks for that) for advice on how best to untangle it.

1 Like

Would welcome a further response on this too as I’m facing the same issues - thanks

Hi! It might be best to reach out to our support team directly for this one :+1: