Xero integration broken?

After a break of a week or so I have just opened Sharesight to process a few trades and dividends. I have multiple cash accounts so every single time I enter a trade/dividend I have to go into the Xero settings in Sharesight and adjust the account to which the transaction should be sent to (a very annoying process which Sharesight doesn’t seem concerned about - there is a longstanding forum topic on this).

This time I found neither the account for trades or dividends was populated in Sharesight. “That’s odd” I thought, but I was able to simply select the right Xero account from the drop down list. However, I couldn’t save my selection as I discovered that the accounts for franked and unfranked dividends were also not populated.

I clicked on each field to open the drop down list of Xero accounts, but the accounts I needed were not in the drop down list (but other accounts were). Even more strangely, when I clicked on the drop down list for other items (eg interest received) I could see the dividend accounts listed.

Anybody have any idea why this would be occurring or what I can do to resolve it?

Update - I have disconnected Sharesight from Xero and reconnected. Still no joy - cannot map my transactions in Sharesight to Xero; cannot map the accounts for trades to the bank accounts in Xero.

When trying to map a bank account Sharesight returns the following error: “Select Bank Account has an invalid GL code”.

For what its worth I have just discovered exactly the same when trying to set up a new portfolio. I am unable to link it due to “invalid GL code” and all existing portfolios seem to have lost the link to their bank accounts.

I am seeing the same thing. It has worked flawlessly for years until now.

A week later and no fix in site, or even any suggestion as to when it might be fixed…

I raised a support ticket at the time and have followed up with another email this morning to stress the urgency.

The initial ticket was acknowledged, but no word since…Very disappointing.

Hi All,

Thanks for the feedback regarding this, our team has been aware of the issues mentioned and is currently working through a resolution. I’ll update this thread once we have the fix deployed into Sharesight.

Thanks! :grinning:

1 Like

Just checked and looks like this has been fixed. Thanks Ricky and team

Yes, we deployed a fix yesterday for this one which should resolve the issue! :+1:

1 Like

I still have problems.

  1. The bank balance in Xero is not reflecting back into Sharesight. At least I can select the account now, but it does not do anything.
  2. Franked/Unfranked dividends can only be allocated to ‘Revenue’ account types in Xero. Previously ‘Other Income’ was also allowed. I need to use ‘Other Income’.

Come on team - just roll back the change, and test more thoroughly in your UAT environment before you release this sort of change into Production.

I’ve passed this on to our product team to investigate, I’ll update the thread with any updates as they come through :+1:

Still broken for me too.

@Brett_F @djb we’ve deployed a few fixes for some of the mentioned issues, are you able to see if this has resolved some of the things you’re experiencing?

  • The bank balance in Xero is not reflecting back into Sharesight. At least I can select the account now, but it does not do anything. - NOT FIXED.

  • Franked/Unfranked dividends can only be allocated to ‘Revenue’ account types in Xero. Previously ‘Other Income’ was also allowed. I need to use ‘Other Income’ - FIXED.

-Brett

This is still not fixed - after 4 weeks???

It looks like was fixed and started working overnight.

Yep! Our product team deployed this fix late last night. You should see things syncing as per normal now :+1: